В продолжение этой темы — использование Xubuntu на старом ноутбуке. Предыдущая версия 14.04 этой лёгкой операционки мне очень понравилась. Но время шло, вышла новая LTS-версия. Решил установить её. Устанавливал, как и прошлый раз с нуля, используя записанный DVD-диск.

Процессор без PAE

Повторяться не буду, подробности были в предыдущей статье. В новых версиях 16.04 систем семейства Ubuntu используется тот же подход для преодоления ошибки, связанной с ядром системы. Только здесь немного поменялся формат того, как мы вписываем опцию forcepae.

Итак, при старте с инсталляционного носителя сразу жмём кнопку «F6», выбираем русский язык, наводим маркер меню на «Установить Xubuntu» и жмём снова кнопку «F6», потом сразу «Esc». Теперь у нас есть строка с параметрами, куда мы можем вписать дополнительные. В конце этой строки знаки «—», вот именно перед ними надо вписать «forcepae». Получится так:

Параметр forcepae при установке Xubuntu

Всё, теперь жмём «Enter» и продолжаем установку.

Произошла ошибка

Xubuntu 16.04 устанавливается в обычном режиме, никаких видимых проблем сразу нет. Они появляются позже. При первом старте системы сразу появляется сообщение, что необходимо установить недостающие языковые пакеты.

Как я понимаю, в процессе инсталляции системы это сделать не получилось. Не получится и сейчас! Вообще, при попытке что-либо установить в систему получаем красивую ошибку:

Xubuntu: произошла ошибка

Система для исправления предлагает выполнить в консоли команду:

sudo apt-get install -f

Однако, это выявляет ещё ряд проблем:

nastya@nastya-nb:~$ sudo apt-get clean
nastya@nastya-nb:~$ sudo apt-get -f install
Чтение списков пакетов... Готово
Построение дерева зависимостей 
Чтение информации о состоянии... Готово
Исправление зависимостей... Готово
The following additional packages will be installed:
 linux-image-4.4.0-34-generic
Предлагаемые пакеты:
 fdutils linux-doc-4.4.0 | linux-source-4.4.0 linux-tools
НОВЫЕ пакеты, которые будут установлены:
 linux-image-4.4.0-34-generic
обновлено 0, установлено 1 новых пакетов, для удаления отмечено 0 пакетов, и 0 пакетов не обновлено.
не установлено до конца или удалено 3 пакетов.
Необходимо скачать 17,4 MБ архивов.
После данной операции, объём занятого дискового пространства возрастёт на 40,3 MB.
Хотите продолжить? [Д/н] 
Get:1 http://ru.archive.ubuntu.com/ubuntu xenial-updates/main i386 linux-image-4.4.0-34-generic i386 4.4.0-34.53 [17,4 MB]
Получено 17,4 MБ за 12с (1 368 kБ/c) 
(Чтение базы данных ... на данный момент установлен 188981 файл и каталог.)
Подготовка к распаковке .../linux-image-4.4.0-34-generic_4.4.0-34.53_i386.deb ...
This kernel does not support a non-PAE CPU.
dpkg: ошибка при обработке архива /var/cache/apt/archives/linux-image-4.4.0-34-generic_4.4.0-34.53_i386.deb (--unpack):
 подпроцесс новый сценарий pre-installation возвратил код ошибки 1
Examining /etc/kernel/postrm.d .
run-parts: executing /etc/kernel/postrm.d/initramfs-tools 4.4.0-34-generic /boot/vmlinuz-4.4.0-34-generic
run-parts: executing /etc/kernel/postrm.d/zz-update-grub 4.4.0-34-generic /boot/vmlinuz-4.4.0-34-generic
При обработке следующих пакетов произошли ошибки:
 /var/cache/apt/archives/linux-image-4.4.0-34-generic_4.4.0-34.53_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
nastya@nastya-nb:~$

Благо, среди всего этого промелькнуло: «This kernel does not support a non-PAE CPU». Вот так сюрприз! Снова не нравится процессор. При установке обновлений и приложений в Xubuntu 14.04 такого не было!

Новой версии Xubuntu 16.04 оказывается недостаточно прописать параметр forcepae при инсталляции. Дополнительно требуются следующие действия:

В файле /etc/default/grub находим строчку:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

Дописываем в неё «forcepae»:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash forcepae"

Для редактирования файла можно воспользоваться редактором nano:

sudo nano /etc/default/grub

Интерфейс у редактора несколько своеобразный, непривычный, но зато этот редактор есть в Linux по умолчанию. Сейчас выбора нет, программы устанавливать мы не можем! Поэтому как-нибудь, с горем пополам, редактируем и сохраняем в файле всего одну строчку.

После этого выполняем:

sudo update-grub

И перезапускаем компьютер. Мне помогло! Теперь можем устанавливать языковые пакеты и всё прочее обычными средствами, используя графический интерфейс Xubuntu.

Решения нашёл здесь. Что странно, оно предназначено для версии 14.04. Однако, как я уже сказал, с ней у меня не было таких проблем. Вот такие чудеса.

Подключение к WiFi

И ещё об одной проблеме, которой у меня тоже не было в Xubuntu 14.04. Для подключения к WiFi требуется нажать значок сети возле часов (стрелки вверх-вниз). Там выбираем WiFi-сеть с названием своего роутера. Вводим пароль.

Обычно сразу после этого происходит подключение к WiFi. Однако, в 16.04 всё не так просто! Вводим пароль, а в итоге ничего не происходит. Совсем ничего! Нет подключения. Нет никаких сообщений и ошибок. Я сначала думал, что ввожу пароль неправильно, пробовал несколько раз, но в ответ полная тишина.

Чтобы всё же подключится к WiFi, необходимо через тот же значок в трее, в том же меню, выбрать пункт «Изменить соединения». В открывшемся окне в группе WiFi выбрать то же самое соединение, которое пытались подключить. Нажимаем кнопку «Изменить». Ничего не меняем. Во вкладке «Защита WiFi» вводим ещё раз пароль. Нажимаем «Сохранить». Теперь соединение точно произойдет.

Что странно, позднее я подключался к другой сети WiFi и таких сложностей там уже не было. Почему так, не знаю.

Что в итоге?

В итоге система Xubuntu 16.04 у меня заработала, как положено. Я снова остался доволен. Хотя, первые впечатления были совсем не очень. Ошибки… Плюс то, что языковые пакеты сразу сами не поставились, как результат — некоторые программы, например LibreOffice, Mozilla Firefox имели англоязычный интерфейс. Благо, само всё потом исправилось.

Особых новшеств в Xubuntu 16.04 я не обнаружил. Надо полагать, изменения внутри. Снаружи — привычный уже интерфейс, знакомый набор софта, привычная для работы обстановка.